Installation of Workgroup Database Server

In this guide Workgroup Database Server is abbreviated to WDS.

Prerequisites

For new installations continue with Step 1.

Before installing an upgrade, uninstall any previous version of the Workgroup Data Server. You can save and reuse the snumbat.ini file from the installation directory. Uninstalling the WDS will leave all data untouched.

Note

You will encounter an error message before the setup can be run if another version is installed. The error reads as follows:

Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.

alt text

Note

The Workgroup Database Server (WDS) cannot serve databases that have a higher version number than the WDS installation. For example WDS 16.0 can serve databases to InfoNet 16 or InfoWorks 6 and lower. An InfoNet 16.5 or InfoWorks 6.5 database cannot be created or served by WDS 16.0.

1. Running the Setup

alt text

2. Accept Licence Agreement

alt text

alt text

4. Custom setup

alt text

5. Remove dongles

alt text

6. Start installation

alt text

7. Installation progress

alt text

8. Finish installation

alt text

Configure the WDS

To change the default values of the WDS, you have to place the snumbat.ini file in the install directory of the WDS.

alt text

snmubat.ini looks like this.

# a comment
Port=40000
DataPath=C:\WDS_DB
LogToFile=0
LogLevel=2
DisableReverseDNS=0
AllowDatabaseCreation=1

Run the Service

alt text

Note

If you are connecting the WDS to SQL databases, you will have to make sure the account the service is running on has permission on the SQL or Oracle database (CRUD operations)

Connect with WDS

alt text

New database

alt text

Possible Error messages

Older database

alt text

Newer database

alt text

WDS version is older than Client

alt text